Présentation

Documentation

Bienvenue dans Crypto !

Cette application va vous permettre de stocker de façon sécurisée toutes vos informations confidentielles, tel que les identifiants et mots de passe pour les sites Internet, codes des cartes de paiements, mots de passe pour des documents protégés, codes PIN des téléphones portables, ou tout autre information à votre convenance.

Pourquoi utiliser Crypto plutôt qu'un autre programme ?

La plupart des programmes de ce type utilise le même principe de fonctionnement : codage du mot de passe à l'aide d'une méthode connue ultra-sécurisée (type MD5), puis cryptage de vos données en utilisant le même algorithme pour tous les utilisateurs.

Dans ce cas, si les données cryptées sont accessibles simplement, il suffit de remplacer le codage du mot de passe par un autre dont on connait la valeur. Facile non ? C'est malheureusement une méthode que j'ai déjà pu tester malheureusement !

Par contre, si les données ne sont pas lisibles directement, la méthode sera beaucoup plus compliquée. Dans ce cas, n'importe quel bon hacker pourra modifier le programme pour qu'il accepte même un mot de passe invalide. Evidement, dans ce cas, cela n'est pas faisable par n'importe qui, j'en serai moi-même incapable, mais il n'y a qu'à voir tous les types de 'crack' disponibles pour les programmes du marché (logiciels, jeux, systèmes d'exploitation comme Windows XP ou VISTA, ...).

Comment fonctionne la sécurité dans Crypto ?

Tout d'abord le mot de passe est stocké en utilisant un algorithme de codage au choix de l'utilisateur parmi les plus réputés : MD5, RIPE, SHA256, SHA512 ou HAVAL. Ces méthodes sont même préconisées par des gouvernements (américains ou français) pour le codage des données requérant le plus haut niveau de sécurité. Ceci vous garanti que personne ne pourra trouver votre mot de passe à partir de son codage (au jour de la réalisation de ce programme).

Cela ne suffit pas à sécuriser vos données, car Crypto utilise une base ACCESS pour stocker vos données. Les données étant librement accessibles, la première méthode de contournement évoquée ci-dessus pourrait donc être utilisable ! Pour contourner cette faille, Crypto utilise un algorithme de cryptage des données sensibles qui est propre non seulement à chaque utilisateur mais qui dépend également du mot de passe utilisé.

Ainsi, si quelqu'un utilise la méthode de substitution de mot de passe évoquée ou un crack pour accepter n'importe quel mot de passe, cette personne pourra lire vos données non cryptées mais en aucun cas celle protégées. A l'écran figurera des données incompréhensibles, comme par exemple "OtIlwB8=".

Attention : Toute cette sécurité peut être compromise si vous votre ordinateur est infecté par un logiciel malveillant, type spyware ou keylogger. Ces logiciels interceptent les données que vous saisissez sur votre clavier ou qui s'affichent à l'écran puis les envoient à des pirates via le réseau Internet, de façon transparente. Pensez à vérifier régulièrement votre ordinateur à l'aide d'un anti-virus et anti-spyware tel qu'Avast, SpyBot ou Windows Defender.

Quelles sont les méthodes de codage ou de cryptage ?

Pour stocker le mot de passe, vous pouvez utiliser au choix une des méthodes de "hachage" suivantes :

    • MD5 128bits
    • RIPE 160bits
    • SHA 256bits
    • SHA 512bits
    • HAVAL 256bits

Pour le cryptage de vos données, vous devrez d'abord choisir le codage de la clef Cipher parmis une des méthodes ci-dessus puis ensuite en sélectionnant une des méthodes de "cryptographie symétrique" suivantes :

    • AES (Rijndael)
    • BlowFish
    • Mars
    • Serpent
    • TwoFish

Comme vous pouvez le constater, il y en a pour tous les goûts !

Pour avoir plus d'informations sur toutes ces méthodes, je vous recommande les articles suivants de l'encyclopédie Wikipédia :

Qu'est-ce que le hachage ?

MD5

RIPE

SHA256

SHA512

HAVAL

Qu'est-ce que la cryptographie symétrique ?

AES

BlowFish

Mars

Serpent

TwoFish

Copyright © 2007 - Michaël Duval

This help file has been generated by the freeware version of HelpNDoc


Versions

Documentation

Versions

Il est recommandé de toujours utiliser la dernière version de Crypto.

Vérification automatique :

Par défaut, elle s'effectue via Internet et a lieu automatiquement tous les 7 jours, après vous être identifié. En cas de nouvelle version, un message vous avertira de cette disponibilité et vous proposera d'ouvrir la page Internet correspondante afin de télécharger la nouvelle version. Si vous répondez non, vous n'aurez pas d'autre avertissement avant 7 jours.

Si votre version est à jour ou qu'un problème a eu lieu, aucun message ne s'affichera, afin de ne pas perturber votre utilisation de Crypto.

Reportez-vous au chapitre "Paramètres" pour le réglage de la vérification automatique.

Vérification manuelle :

Vous pouvez vérifier ponctuellement si une nouvelle version est disponible en utilisant le menu "Outils / Vérifier la version via Internet".

Avec cette méthode, vous serez toujours averti du résultat, qu'une version plus récente existe ou non, ou bien qu'un problème a eu lieu.

Votre version :

Pour connaitre la version que vous utilisez, cliquez sur le menu "Outils / A propos" :


1er lancement

Documentation

1er lancement de Crypto

La première fois que vous exécutez Crypto, il vous foudra créer un nouvel utilisateur. Pour ce faire, cliquez sur le bouton [image] en bas à gauche de l'écran de connexion :

Vous aurez alors l'écran de gestion des utilisateurs, dans lequel vous devrez :

    1. Saisir votre nom d'utilisateur
    2. Saisir votre mot de passe
    3. Confirmer votre mot de passe (pour éviter les erreurs de frappes)
    4. Cocher ou non l'affichage du détail de vos informations sur l'écran de connexion
    5. Sélectionner la méthode de hachage pour le mot de passe
    6. Sélectionner la méthode de hachage pour la méthode de cryptage des données (Cipher)
    7. Sélectionner la méthode de cryptage pour les données

Une fois toutes les zones renseignées, vous pourrez valider pour enregistrer votre nouvel utilisateur à l'aide du bouton [image].

Si vous souhaitez créer un autre utilisateur, cliquez sur le bouton [image], sinon quitter la gestion des utilisateurs à l'aide du bouton [image].

Vous voilà donc revenu à l'écran de connexion. Par défaut, le premier utilisateur est sélectionné. Si vous souhaitez en utiliser un autre, cliquez sur son nom dans la liste de gauche.

Saisissez le mot de passe correspondant à l'utilisateur sélectionné, puis cliquez sur [image].

Vous voici maintenant dans le coeur du programme !

Reportez-vous aux sections suivantes pour utiliser le programme...


Nouvelle fiche

Utilisation courante

Saisir une nouvelle fiche

Si ce n'est pas déjà fait, accédez à la gestion des fiches à l'aide du bouton [image] ou bien du menu "Fiches / Gestion des fiches".

Sélectionnez, à l'aide de la liste déroulante en haut à gauche, la catégorie dans laquelle vous souhaitez créer une nouvelle fiche, par exemple "Logiciels", puis cliquez sur le bouton [image] pour obtenir une fiche de saisie vierge.

Complétez les différentes zones, puis validez par le bouton [image] pour enregistrer vos données. Simple non ?

Pour les liens Internet, saisissez bien l'adresse complète, y compris "http://" ou "ftp://". La petit icône [image] vous permettera de lancer directement le lien saisi.

Pour les zones indiquant un programme ou fichier, cliquez sur l'icône [image] pour chercher le fichier sur votre ordinateur. Pour lancer le programme ou ouvrir le document, vous pourrez utiliser ensuite la petite icône [image].


Gérer les fiches

Utilisation courante

Gérer les fiches existantes

Une fois que vous avez créé un fiche, vous pouvez l'utiliser de différentes manières :

Visualisation :

La méthode la plus simple..

Si ce n'est pas déjà fait, accédez à la gestion des fiches à l'aide du bouton [image] ou bien du menu "Fiches / Gestion des fiches".

Sélectionnez, à l'aide de la liste déroulante en haut à gauche, la catégorie dans laquelle votre fiche est enregistrée, par exemple "Logiciels".

En dessous de la catégorie va apparaître toutes les fiches déjà créées, cliquez sur le nom de la fiche souhaitée pour l'afficher.

Si votre fiche contient un lien Internet (web, ftp, mail, news, etc...), utilisez l'icône [image] pour le lancer.

Pour une zone programme ou fichier, utilisez l'icône [image] pour ouvrir le programme correspondant.

Modification :

Procédez directement à votre modification puis validez par le bouton [image].

Si vous souhaitez annuler votre changement, utilisez le bouton [image].

Duplication :

Vous aurez peut-être parfois à saisir des fiches qui se ressemblent. Dans ce cas, plutôt que de saisir 2 fois complètement les fiches, saisissez et validez d'abord la première, puis utilisez le bouton [image] pour créer une copie de la fiche ayant son nom avec un numéro en suffixe.

Modifier ensuite son nom et les données qui diffèrent puis validez à l'aide du bouton [image].

Suppression :

Si vous avez créé une fiche par erreur ou bien qu'une soit devenue obsolète, sélectionnez la puis cliquez sur le bouton [image] pour la supprimer de façon définitive. Un demande de confirmation sera quand même nécessaire avant !


Nouvelle catégorie

Utilisation courante

Saisir une nouvelle catégorie

Bien que Crypto soit livré avec plusieurs catégories, vous souhaiterez certainement en créer de nouvelles.

Si ce n'est pas déjà fait, accédez à la gestion des catégories à l'aide du bouton [image] ou bien du menu "Catégories / Gestion des catégories".

Cliquez directement sur le bouton [image] pour obtenir une fiche de saisie vierge. Indiquez ensuite le nom de la catégorie.

Pour changer l'icône associée, cliquez sur [image], cela va ouvrir les icônes utilisées par Windows. Vous pourrez également choisir n'importe quelle icône soit grace à un fichier de type .ICO, soit à partir d'un programme (.EXE) ou d'une librairie (.DLL).

Validez votre saisie à l'aide du bouton

Vous voilà maintenant avec une nouvelle catégorie, ayant comme unique champ "Nom" :

Pour créer ne nouveaux champs, rendez-vous au chapitre suivant...


Gérer les champs

Utilisation courante

Gérer les champs d'une catégorie

Après avoir créé une nouvelle catégorie, ou pour modifier les existantes, vous aurez envie de gérer les champs associés.

Si ce n'est pas déjà fait, accédez à la gestion des catégories à l'aide du bouton [image] ou bien du menu "Catégories / Gestion des catégories" puis sélectionnez dans la liste de gauche la catégorie dont vous voulez modifier les champs.

Ajouter un champ :

Cliquez sur le bouton [image] pour renseigner les informations du nouveau champ :

    • Le nom (par exemple "mot de passe")
    • Le type :
      • Alphanumérique
      • Préformaté (pour forcer la saisie dans un format bien précis. Voir le chapitre correspondant)
      • Date (affiche un petit calendrier pour sélectionner une date)
      • Fichier local. Affiche les icônes [image] et [image] pour choisir et ouvrir un fichier sur votre ordinateur
      • Lien Internet. Affiche l'icône [image] permettant d'accéder à un lien Internet (page Web, FTP, News, etc...)
    • Cochez la case "Donnée à crypter [image] " pour que l'information saisie dans ce champ soit crypté.

Validez votre saisie à l'aide du bouton [image]. Pour abandonner, utilisez le bouton [image].

Quand crypter ou non un champ ?

Crypter des informations est une opération qui prend un certain temps. Plus vous avez de champs à encoder dans une catégorie et plus long sera son enregistrement ou son affichage. De nos jours, les ordinateurs sont assez puissants pour que cela soit imperceptible.

Certains champs doivent être cryptés, comme les mots de passe et les codes. Parfois il est bon aussi de faire de même avec les identifiants ou les e-mail, au cas où les données seraient récupérées par une personne mal intentionnée.

Par contre, il est un peu inutile de crypter les données comme 'Obersvation' ou le nom d'un site, mais rien ne vous empêche de tout crypter si cela ne ralenti pas votre système.

Il faut aussi prendre en compte le temps de traitement en cas de re-cryptage global de toutes vos données, dans le cas d'un changement de mot de passe ou de méthode de cryptage.

Modifier un champ :

Rien de plus simple, sélectionnez-le dans la liste, modifier son nom, son type ou le cryptage puis validez la modification avec [image].

Si vous changez le cryptage d'une donnée et que des fiches existent déjà, le programme devra crypter ou décrypter ces données existantes. Reportez au chapitre "Re-cryptage des données" pour cette opération.

Pour le champ créé par défaut "Nom", vous ne pourrez modifier que son nom, en aucun cas son type ou son cryptage.

Supprimer un champ :

Après l'avoir sélectionné, utilisez le bouton [image]. Après une demande de confirmation, le champ sera définitivement supprimé.

Modifier l'ordre des champs :

Tous les champs que vous créez peuvent être placés dans n'importe quel ordre. Après avoir sélectionné le champ à déplacer, utiliser le bouton [image] pour le faire monter d'une position, ou bien le bouton [image] pour le faire descendre.

Le champ créé par défaut "Nom" n'est pas modifiable, il est toujours en 1ère position.


Gérer les catégories

Utilisation courante

Gérer les catégories existantes

Modification :

Si ce n'est pas déjà fait, accédez à la gestion des catégories à l'aide du bouton [image] ou bien du menu "Catégories / Gestion des catégories" puis sélectionnez dans la liste de gauche la catégorie que vous souhaitez modifier.

Modifiez le nom de la catégorie ou son icône puis validez à l'aide du bouton [image].

Pour annuler votre changement, utilisez le bouton [image].

Duplication :

Vous aurez peut-être parfois à gérer des catégories qui se ressemblent. Dans ce cas, plutôt que de les saisir 2 fois complètement, saisissez et validez d'abord la première (avec les champs correspondants), puis utilisez le bouton [image] pour créer une copie de la catégorie ayant son nom avec un numéro en suffixe.

Modifier ensuite son nom et son icône puis validez à l'aide du bouton [image].

Procédez ensuite à la modification des champs.

Suppression :

Si vous avez créé une catégorie par erreur ou bien qu'une soit devenue obsolète, sélectionnez la puis cliquez sur le bouton [image] pour la supprimer de façon définitive. Un demande de confirmation sera quand même nécessaire avant !

Si un autre utilise cette catégorie, alors cette dernière ne sera pas supprimée, seulement vos fiches. Pour supprimer définitivement la catégorie, il faudra que les autres utilisateurs n'aient plus de fiches non plus dedans.


Champ préformaté

Utilisation avancée

Utiliser les champs préformatés

Ce type de champ est vraiment particulier et nécessite que l'on y consacre une partie entière dans ce manuel.

Le champ préformaté permet de forcer l'utilisateur à respecter un format bien défini dans sa saisie. C'est le cas, par exemple, pour un numéro de téléphone (01-30-30-30-30), un numéro de carte bleue (0123 0123 0123 0123), un code sur 4 chiffres uniquement (1234), un texte obligatoire en minuscule ou majuscule, etc...

Dans ce cas, vous devrez saisir dans le champ "Préformatage" ce que l'on appelle un masque de saisie qui décrit le format à respecter.

Un masque de saisie est composé de trois parties, chacune séparée par un point-virgule (voir plus bas pour les explications détaillées) :

    • La première partie définit le masque à proprement parler.
    • La deuxième partie indique si les caractères litéraux doivent être enregistrés ou pas (facultatif).
    • La dernière partie indique quel caractère utiliser pour matérialiser les emplacements à saisir (facultatif).

Si aucun masque n'est précisé, l'utilisateur pourra saisir ce qu'il souhaite, comme s'il s'agissait d'un champ Alphanumérique normal.

Pour vous aider à réaliser votre masque, vous pouvez cliquer sur le bouton [image] à droite du champ "Préformatage" pour afficher une fenêtre d'aide à la saisie.

Définition du masque :

La première partie du masque de saisie peut contenir les caractères suivants :

!

Si un caractère ! apparaît dans le masque, les caractères facultatifs sont représentés comme des espaces de début.

Si le caractère ! n'est pas présent, les caractères facultatifs sont représentés par des espaces de fin.

>

Si un caractère > apparaît dans le masque, tous les caractères suivants sont en majuscules jusqu'à ce que la fin du masque soit atteinte ou qu'un caractère < soit rencontré.

<

Si un caractère < apparaît dans le masque, tous les caractères suivants sont en minuscules jusqu'à ce que la fin du masque soit atteinte ou qu'un caractère > soit rencontré.

<>

Si ces deux caractères apparaissent ensemble dans un masque, aucune vérification majuscules/minuscules n'a lieu et le texte est formaté selon les majuscules et minuscules saisies par l'utilisateur

\

Les caractères qui suivent un caractère \ sont littéraux. Utilisez ce caractère lorsque vous souhaitez qu'un caractère spécial du masque soit un caractère littéral inclus dans le texte (\0 affichera 0, \! affichera !, \<\> affichera <>, etc...).

L

Le caractère L rend obligatoire un caractère alphabétique à cette position. Il s'agit des caractères A-Z, a-z et des lettres accentuées (pas de chiffre).

l

Le caractère l (L minuscule) autorise un caractère alphabétique à cette position, il est donc facultatif.

A

Le caractère A rend obligatoire un caractère alphanumérique à cette position.Il s'agit des caractères A-Z, a-z, 0-9 et des lettres accentuées.

a

Le caractère a autorise un caractère alphanumérique à cette position, il est donc facultatif.

C

Le caractère C rend obligatoire un caractère quelconque à cette position.

c

Le caractère c autorise un caractère quelconque à cette position, il est donc facultatif.

0

Le caractère 0 (zéro) rend obligatoire un chiffre à cette position.

9

Le caractère 9 autorise un chiffre à cette position, il est donc facultatif.

#

Le caractère # autorise un chiffre ainsi que les signes plus (+) et moins (-) à cette position, il est donc facultatif.

:

Le caractère : est utilisé pour séparer les heures, les minutes et les secondes dans une heure. Si le caractère de séparation des heures, des minutes et des secondes défini par les paramètres régionaux du panneau de configuration de windows est différent, ce caractère sera utilisé à la place de :.

/

Le caractère / est utilisé pour séparer les jours, les mois et les années dans une date. Si le caractère de séparation des jours, des mois et des années défini par les paramètres régionaux du panneau de configuration de windows est différent, ce caractère sera utilisé à la place de /.

_

Le caractère _ (sous-trait) insère automatiquement un espace dans le texte. Si l'utilisateur saisit des espaces dans le champ, le curseur saute les caractères _.

;

Le caractère ; est utilisé pour séparer les trois parties d'un masque de saisie.

Tout caractère n'apparaissant pas dans le tableau précédent peut être utilisé dans la première partie du masque comme caractère littéral.

Un caractère littéral apparaît automatiquement dans le champ et ne peut être modifié par l'utilisateur.

Enregistrer les caractères litéraux :

La deuxième partie du masque ne contient qu'un seul caractère indiquant s'il faut enregistrer les caractères littéraux du masque.

S'il s'agit d'un 0 (zéro), les caractères littéraux ne seront pas stockés. S'il s'agit d'un 1, il le seront.

Par exemple, le masque d'un numéro de téléphone peut être défini par le texte suivant : 00-00-00-00-00

Si vous mettez un 0 dans la deuxième partie, Crypto sauvegardera : 1234567890

Si vous mettez un 1 dans la deuxième partie, Crypto sauvegardera : 12-34-56-78-90

Cela n'a d'incidence que si vous changez le type ou le préformatage du champ.

Si vous n'indiquez rien dans la deuxième partie, la valeur 1 sera prise par défaut.

Caractère de saisie :

La troisième partie du masque indique le caractère apparaissant dans le champ de saisie pour matérialiser les caractères à saisir par l'utilisateur.

C'est par défaut le caractère _ qui est utilisé.

Exemples :

!00\-00\-00\-00\-00;1;_ affichera __-__-__-__-__ et permettra de saisir "01-99-88-77-66"

!99 >L<LL 0000;1;_ affichera __ ___ ____ et permettra de saisir "1 Déc 2000" ou bien "Jan 1999"

!0000000000000\-99;0;_ affichera _____________-__ et permettra de saisir "1234567890123-99" ou bien "1234567890123"


Gérer les utilisateurs

Utilisation avancée

Gérer les utilisateurs

Cliquez sur le menu "Utilisateurs / Gestion des utilisateurs" pour accéder à l'écran de gestion des utilisateurs :

Modification du mot de passe :

Cliquez sur le bouton [image] pour accéder à l'écran permettant le changement de mot de passe.

Plus d'information dans le chapitre "Changer de mot de passe".

Autres modifications :

Procédez directement à vos modifications (Nom, résumé ou les méthodes de cryptage) puis validez par le bouton [image]. Si vous avez modifié les méthodes 'Pour la clef Cipher" ou "Pour les données", vos données cryptées devront être ré-encodés. Pour ce faire, un nouvel écran va s'afficher pour procéder au traitement. Plus d'information dans le chapitre "Re-cryptage des données".

Si vous souhaitez annuler votre changement, utilisez le bouton [image].

Suppression :

Si vous souhaitez supprimer un utilisateur, sélectionnez le puis cliquez sur le bouton [image] pour la supprimer de façon définitive. Vous devrez confirmer la suppression en saisissant le mot de passe associé à l'utilisateur. Toutes les fiches de ce dernier seront également supprimées.


Changer de mot de passe

Utilisation avancée

Changer votre mot de passe

Cliquez sur le menu "Utilisateurs / Gestion des utilisateurs" pour accéder à l'écran de gestion des utilisateurs, puis utilisez le bouton [image] pour accéder à l'écran permettant le changement de mot de passe :

Vous devrez entrer les 3 informations suivantes afin de procéder à la modification :

    • Votre ancien mot de passe (l'actuel)
    • Votre nouveau mot de passe
    • Une nouvelle fois votre nouveau mot de passe pour confirmation

Vous n'avez plus qu'à valider le changement avec le bouton [image].

Le programme procédera ensuite à un nouveau cryptage de vos données confidentielles.

Par précaution, une sauvegarde est réalisée automatiquement et vous pourrez suivre l'évolution du traitement dans la zone de rapport en bas de la fenêtre.

En cas d'erreur, cette sauvegarde sera restaurée automatiquement, afin d'éviter la perte de vos données.

Si le traitement s'est déroulé correctement, vous devrez controler quelques fiches afin de vous assurer de la bonne lisibilité des vos données cryptées. Vous pourrez ensuite supprimer manuellement la sauvegarde qui a été réalisée avant traitement. Plus d'informations sur la suppression des sauvegardes dans ce chapitre.


Re-cryptage des données

Utilisation avancée

Recryptage des données

Certaines manipulations obligent à re-crypter vos données confidentielles, c'est le cas si vous changer le cryptage d'un champ (gestion des champs) ou bien si vous modifier les méthodes de cryptage (gestion des utilisateurs).

Dans ces cas, vous verrez s'afficher cet écran :

Par précaution, une sauvegarde est réalisée automatiquement et vous pourrez suivre l'évolution du traitement dans la zone de rapport en bas de la fenêtre.

Procédez au re-cryptage de vos données à l'aide du bouton [image] ou bien annulez tout avec [image].

En cas d'erreur ou d'abandon, cette sauvegarde sera restaurée automatiquement, afin d'éviter la perte de vos données, si vous avez modifié les méthodes de cryptage.

Si vous avez modifié le cryptage d'un champ, la restauration n'est pas automatique, car le traitement pourra être repris ultérieurement, soit en lançant à nouveau le traitement, soit lorsque vous relancerez le programme. Tant que tous les champs n'auront pas été re-cryptés, vous ne pourrez pas modifier le cryptage des champs concernés.

Si le traitement s'est déroulé correctement, vous devrez controler quelques fiches afin de vous assurer de la bonne lisibilité des vos données cryptées. Vous pourrez ensuite supprimer manuellement la sauvegarde qui a été réalisée avant traitement. Plus d'informations sur la suppression des sauvegardes dans ce chapitre.


Sauvegarder

Sauvegardes-Restaurations

Effectuer une sauvegarde

Il est important d'effectuer régulièrement des sauvegardes de vos données. On n'est jamais à l'abris d'une défaillance du logiciel, de Windows ou de l'ordinateur. Ca serait quand même dommage de tout perdre alors qu'il est possible de réaliser une sauvegarde rapide en 1 seul clic !

Sauvegarde rapide :

Cette méthode effectue une sauvegarde de la manière la plus rapide. Une copie de vos données est réalisée dans un fichier situé dans le même répertoire que le programme.

Une sauvegarde rapide est toujours effectuée automatiquement avant de réaliser des opérations délicates, comme le changement d'un mot de passe ou le type de cryptage des données.

Sauvegarde manuelle :

En plus des sauvegardes rapides, il est recommandé de sauvegarder vos données sur un support amovible, comme une clef USB par exemple.

Pour effectuer cette manipulation, utilisez le menu "Outils / Gérer les sauvegardes" puis cliquez sur le bouton [image]. Indiquez ensuite à quel endroit vous souhaitez réaliser votre sauvegarde.

Reportez au chapitre "Paramètres" pour l'emplacement par défaut de la sauvegarde manuelle.

Nom des sauvegardes :

Que ce soit les sauvegardes automatiques ou manuelles, tous les fichiers sont nommés de la même manière : "Crypto_AAAAmmJJhhMMssXXX", où les lettres correspondent à :

    • AAAA : année sur 4 chiffres (2007)
    • mm : mois sur 2 chiffres (02)
    • JJ : jour sur 2 chiffres (27)
    • hh : heure sur 2 chiffres (10)
    • MM : minutes sur 2 chiffres (30)
    • ss : secondes sur 2 chiffres (02)
    • XXX : 3 lettres pour indiquer le type de la sauvegarde (rapide, manuelle, avant mise à jour d'une version, etc..)

Une sauvegarde rapide datant du 27/02/2007 à 10:30:02, sera donc nommée "Crypto_20070227103002rap.mdb". L'extension .mdb correspond à un fichier ACCESS.


Restaurer

Sauvegardes-Restaurations

Restaurer une sauvegarde

En cas d'anomalie ou d'erreur, vous serez amené à restaurer une sauvegarde. Pour effectuer cette restauration, utilisez le menu "Outils / Gérer les sauvegardes".

Sauvegarde rapide :

L'écran de gestion des sauvegardes, affiche tout d'abord la liste des sauvegardes rapides. Pour en restaurer une, sélectionnez là puis cliquez sur le bouton [image].

Une fois la restauration effectuée, vous serez amené directement à l'écran de connexion pour vous identifier à nouveau.

Sauvegarde manuelle :

En dessous de la liste des sauvegardes rapides, sélectionnez la ligne "Utiliser une autre sauvegarde..." puis cliquez sur le bouton [image]. Vous devrez alors localiser le fichier à restaurer avant que le processus commence.

Comme précédement, vous serez amené directement à l'écran de connexion une fois la restauration effectuée.


Supprimer

Sauvegardes-Restaurations

Supprimer une sauvegarde

Il est inutile de garder trop de sauvegardes automatiques. Il convient de faire de temps en temps un peu de ménage.

Pour effectuer ces suppressions, utilisez le menu "Outils / Gérer les sauvegardes", sélectionnez la sauvegarde à supprimer puis cliquez sur [image]. Après une demande de confirmation, le fichier sera définitivement supprimé de votre ordinateur.


Outils

Copyright © 2007 - Michaël Duval

This help file has been generated by the freeware version of HelpNDoc


Paramètres

Outils

Paramètres

Plusieurs options peuvent être paramétrées dans Crypto, pour y accéder, utilisez le menu "Outils / Paramètres" :

Vérification automatique des nouvelles versions :

En cochant cette case, Crypto vérifiera automatiquement si une nouvelle version existe. Cette vérification a lieu après avoir saisie votre mot de passe. Par défaut, la vérification est activée et a lieu tous les 7 jours.

Pour modifier cet intervale, saisissez le nombre de jours (entre 1 et 30) dans la zone prévue à cet effet.

Voir le chapitre "Versions".

Sauvegarder la taille et la position des fenêtres en quittant :

Si cette case est cochée, vous retrouverez la fenêtre principale, l'écran de connexion et la gestion des utilisateurs avec les tailles et positions qu'elles avaient lors de votre dernière utilisation du programme. Ceci est utile si vous avez des fiches qui dépassent, en largeur ou plus certainement en hauteur, la taille définie par défaut, vous évitant ainsi d'avoir à redimensionner la fenêtre à chaque utilisation.

Pour remettre les fenêtres à leurs tailles et positions d'origine, cliquez sur le bouton [image].

Ne garder qu'un nombre limité de sauvegardes :

Par défaut Crypto ne garde sur votre disque que les 10 dernières sauvegardes effectuées, les autres sont définitivement supprimées de votre ordinateur.

Pour modifier ce nombre, indiquez la valeur souhaitez dans le zone prévue (entre 1 et 99).

Pour désactiver complètement la suppression automatique des sauvegardes, décochez cette case.

Cette option ne concerne que les sauvegardes effectuées dans le répertoire de l'application (sauvegardes rapides ou automatiques effectuée par Crypto). Il est recommandé d'effectuer vos sauvegardes manuelles dans un autre répertoire, ou mieux sur un autre support comme une clef USB.

Emplacement par défaut des sauvegardes manuelles :

Par défaut, les sauvegardes manuelles s'effectuent dans le répertoire de l'application. Si vous les effectuez toujours à un autre endroit, vous pouvez indiquer celui-ci dans cette zone. Ainsi, à chaque fois que vous effectuerez une sauvegarde manuelle, elle sera positionnée par défaut dans le répertoire indiqué.

Vous pouvez vous aider du bouton [image] pour rechercher un répertoire sur votre ordinateur.


Thèmes et couleurs

Outils

Thèmes et couleurs

Afin d'être convivial et de correspondre le plus possible à votre thème Windows, vous pouvez modifier les couleurs utilisées par Crypto. Pour y accéder, utilisez le menu "Outils / Thèmes et couleurs" :

4 thèmes pré-paramétrés vous sont proposés :

    • Standard
    • Bleu (par défaut)
    • Gris
    • Vert

Si aucun de ces thèmes ne vous convient, vous pouvez ajuster vos propres couleurs en sélectionnant "Personnalisé" puis en cliquant sur les différentes couleurs pour les modifier une à une :

Si vous n'aimez pas les couleurs que vous avez choisies, vous pouvez revenir aux couleurs par défaut en cliquant sur [image].

Abréviations et termes :

Par manque de place, certains termes sont abrégés ou réduits à une description courte :

sél. (sélectionné) : indique un controle qui est sélectionné (zone de saisie, bouton, liste) et le libellé associé à ce dernier.

sur. (survolé) : indique la couleur d'un bouton au passage de la souris dessus.

début & fin : plusieurs controles utilisent un dégradé de couleurs. Vous pouvez donc indiquer la couleur de début et de fin du dégradé voulu.


Sauvegarder rapidement

Outils

Effectuer une sauvegarde rapide

Il est important d'effectuer régulièrement des sauvegardes de vos données. On n'est jamais à l'abris d'une défaillance du logiciel, de Windows ou de l'ordinateur. Ca serait quand même dommage de tout perdre alors qu'il est possible de réaliser une sauvegarde rapide en 1 seul clic !

Cette méthode effectue une sauvegarde de la manière la plus rapide. Une copie de vos données est réalisée dans un fichier situé dans le même répertoire que le programme.

Une sauvegarde rapide est toujours effectuée automatiquement avant de réaliser des opérations délicates, comme le changement d'un mot de passe ou le type de cryptage des données.

Reportez vous aux chapitres "Sauvegarder", "Restaurer" et "Paramètres" un complément d'information.


Gestion des sauvegardes

Outils

Gérer les sauvegardes

Pour une utilisation plus avancée des sauvegardes, utilisez le menu "Outils / Gérer les sauvegardes".

Liste des sauvegardes :

Cet écran vous affiche la liste de toutes les sauvegardes qui se trouvent dans le répertoire de l'application, avec la date et heure de réalisation ainsi que le motif de la sauvegarde (rapide, manuel, avant la mise à jour d'une version, avec un changement de mot de passe ou bien avec un re-cryptage des données confidentielles).

La dernière ligne vous permet de choisir une autre sauvegarde à restaurer.

Sauvegarder :

Pour effectuer une sauvegarde manuelle, que vous pouvez placer dans n'importe quel répertoire ou support, cliquez sur le bouton [image] puis sélectionnez ensuite dans quel répertoire vous souhaitez la réaliser.

Reportez au chapitre "Paramètres" pour l'emplacement par défaut de la sauvegarde manuelle.

Supprimer :

Il est inutile de garder trop de sauvegardes rapides ou automatiques. Il convient de faire de temps en temps un peu de ménage.

Pour effectuer ces suppressions, sélectionnez la sauvegarde à supprimer dans la liste puis cliquez sur [image]. Après une demande de confirmation, le fichier sera définitivement supprimé de votre ordinateur.

Reportez au chapitre "Paramètres" pour la suppression automatique des sauvegardes.

Restaurer :

Pour restaurer les données (fiches, catégories et utilisateurs) d'une sauvegarde qui figure dans la liste, sélectionnez-la puis cliquez sur [image].

Si vous souhaitez utiliser une sauvegarde manuelle non listée, sélectionnez la ligne "Utiliser une autre sauvegarde..." puis cliquez sur le bouton [image]. Vous devrez alors localiser le fichier à restaurer avant que le processus commence.

Vous serez amené directement à l'écran de connexion une fois la restauration effectuée.


Mini SQL

Outils

Mini SQL

Cet outils permet d'exécuter des requêtes SQL compatibles avec MS ACCESS, ceci pour d'éventuelles maintenances en cas de problème sur vos données.

Il n'est évidement pas recommandé d'utiliser cet outil si vous ne maitrisez ni SQL, ni la structure de la base de données.


Vérifier la version via Internet

Outils

Versions

Il est recommandé de toujours utiliser la dernière version de Crypto.

Vous pouvez vérifier manuellement si une nouvelle version est disponible en utilisant le menu "Outils / Vérifier la version via Internet".

Avec cette méthode, vous serez toujours averti du résultat, qu'une version plus récente existe ou non, ou bien qu'un problème a eu lieu.

Reportez-vous aux chapitres "Paramètres" et "Versions" pour la gestion de la vérification automatique.


Faire un don

Documentation

Faire un don !

Crypto est diffusé de façon gratuite, que ce soit pour une utilisation personnelle ou bien professionnelle.

Néanmoins, vous pouvez m'aider à continuer les développements, que ce soit cette application ou les autres, à l'aide de dons. L'achat des outils nécessaires au développement n'est pas anodin...

Ils sont réalisés de façon sécurisée via le système PayPal.

Vous pouvez y accéder via le menu "Aide", puis en choisissant soit un des montants préindiqués (5, 10 ou 15 €) soit avec un montant libre.

Je vous remercie par avance !!


Remerciements

Documentation

Remerciements

Pour leurs participations pendant la phase de test, en me rapportant les bugs et me proposant des nouvelles idées ou des modifications :

    • Crachignol
    • Netcomput
    • Start59
    • StefMidi
    • Tom33

Merci à tous !


Développement

Documentation

Développement

Crypto est développé avec une version originale de Turbo Delphi Professionnel de CodeGear / Borland. Vous pouvez vous procurer gratuitement une version personnelle, intitulée Turbo Delphi Explorer.

Les composants non commerciaux suivants sont égalements utilisés :

Bibliothèque Jedi VCL 3.30

DCPcrypt Cryptographic Component Library v2 Beta 3

Thany PngComponents 1.0 RC3 se basant eux-mêmes sur la librairie PNGDelphi

Le fichier d'aide (ce que vous êtes en train de lire) a été réalisé avec la version gratuite de HelpNDoc.

Les icônes utilisées ont été récupérées sur Internet à travers différents site les proposant. Ils sont normalement libre de droit. Si ce n'était pas le cas et que vous en êtes l'auteur, merci de me le signaler, soit pour le retirer, soit pour m'en donner l'autorisation et ainsi vous nommer dans cette partie.


Licence

Documentation

Licence d'utilisation de Crypto

(c) 2007 Michaël DUVAL

================================

LISEZ ATTENTIVEMENT CE QUI SUIT

================================

Vous venez d'installer "Crypto", ci après dénommé le LOGICIEL, sur votre ordinateur.

Ce LOGICIEL et ses différents constituants sont protégés en France par les lois sur la propriété intellectuelle ainsi qu'à l'étranger par les conventions internationales sur le droit d'auteur (convention de Berne).

En utilisant ce LOGICIEL vous vous engagez à respecter les droits d'auteur et à veiller à ce que les autres utilisateurs de cet ordinateur les respectent eux-mêmes.

Lisez attentivement les termes et conditions ci-dessous avant d'utiliser ou de distribuer ce logiciel.

L'utilisation ou la distribution du LOGICIEL implique votre accord avec les termes de ce contrat.

================================

LICENCE UTILISATEUR

================================

1/ Le LOGICIEL est fourni tel quel, sans aucune garantie. L'auteur ne saurait voir sa responsabilité engagée en cas de dommages de quelque nature que ce soit subis par l'utilisateur ou des tiers et résultant directement ou indirectement de son utilisation, notamment la perte des données, le piratage des informations confidentielles sous quelque forme que ce soit (logiciel espion, key-logger, hack de la base de données, etc...), ou toute perte financière résultant de son utilisation ou de l'impossibilité de l'utiliser, et ceci même si l'auteur a été prévenu de la possibilité de tels dommages.

2/ Nous vous accordons l'autorisation non exclusive d'utiliser le LOGICIEL en accord avec les termes de ce contrat.

3/ Vous pouvez installer le LOGICIEL sur autant d'ordinateurs que vous le souhaitez.

4/ REDISTRIBUTION.

a) Vous pouvez, dans le cadre d'échanges privés ou de diffusion publique, librement distribuer le LOGICIEL, si vous respectez les conditions suivantes :

- Vous le distribuez gratuitement, sans demander de donation ou de contrepartie en échange.

- Vous distribuez seulement le programme d'installation original du LOGICIEL.

- Vous n'êtes pas autorisé, de quelque manière que ce soit, à distribuer d'autres fichiers faisant partie du LOGICIEL.

b) Vous ne pouvez pas le mettre à disposition sur des sites de téléchargement payant.

c) Pour la distribution commerciale sur des supports physiques (CD-Rom, DVD, ou autres supports), vous devez obligatoirement contacter l'auteur afin d'en obtenir l'autorisation explicite.

7/ PROPRIÉTÉ

Le LOGICIEL, y compris son code, sa documentation, son apparence, sa structure et son organisation, est la propriété exclusive de son auteur, qui en conserve en permanence les droits de propriété. Il est interdit de traduire, décompiler, modifier, adapter, et corriger le LOGICIEL : seul l'auteur est habilité à effectuer ces opérations.

EN CAS DE NON RESPECT DES CLAUSES CI-DESSUS, VOS DROITS D'UTILISATION SONT AUTOMATIQUEMENT RÉSILIÉS. CETTE RÉSILIATION VIENT S'AJOUTER AUX RECOURS EN MATIÈRE PÉNALE, CIVILE OU AUTRE DONT LA SOCIETE ANSHARE PEUT SE PRÉVALOIR.

SI VOUS ETES EN DESACCORD AVEC LES TERMES DE CETTE LICENCE, VEUILLEZ DESINSTALLER IMMEDIATEMENT CE LOGICIEL.